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SDK and initial setup: Outline

» Today:

= How to setup a machine to start developing Android
applications

= An overview of an Android project

= Some useful tools

= Your first Android application
 Maybe on a real device!
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» Historically Android development was in Eclipse
»Download the SDK
»Install the Android plugin

> Now there is Android Studio
»Customized environment
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»For LAM, it’s the same

»If you already use and love Eclipse, go with it

»You might see examples done in both platforms

»You can always import an Eclipse project into Android
Studio

> The inverse is difficult
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Where and how to get it

» G0 to https://developer.android.com/studio/index.html

> Download Android Studio
and the SDK Android Studio

The Official IDE for Android

> = Android Studio provides the fastest tools for building apps on
n s a I a n every type of Android device.
World-class code editing, debugging, performance tooling, a

yo u J re d o n e ! flexible build system, and an instant build/deploy system all

allow you to focus on building unique and high quality apps.

il
i

S
——
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i3 Basic requirements

»How to develop Android applications?
»Linux/Mac OS X/Windows? Doesn’t matter
» A real device is not mandatory

» Code your application in the IDE

» Test it with the emulator
»Deploy it on a real device

Luca Bedogni = Programming with Android — SDK install and initial setup 7



[ ] @ Default Preferences

Appearance & Behavior » System Settings > Android SDK

v Appearance & Behavior Manager for the Android SDK and Tools used by Android Studio
Appearance Android SDK Location: /Users/Ibedogni/Library/Android/sdk Edit

r AndrOid tOOI Menus and Toolbars

v System Settings

SDK Tools = SDK Update Sites |

Each Android SDK Platform package includes the Android platform and sources pertaining to

R an API level by default. Once installed, Android Studio will automatically check for updates.
HTTP Proxy Check "show package details" to display individual SDK components.
. Updates Name API Level Revision Status
- Android 6.0 23 2 Not installed
4 U d t g t API Usage Statistics
se O ge S - Android 5.1.1 22 2 Not installed
Android SDK ™ Android 5.0.1 21 2 Update available
Notifications Android 4.4W.2 20 2 Not installed
and add-ons e | |
Quick Lists Android 4.4.2 19 4 Not installed
T Android 4.3.1 18 3 Not installed
DAL Android 4.2.2 17 3 Not installed
» Editor Android 4.1.2 16 5 Not installed
Plugins ™ Android 4.0.3 15 5 Installed
H " . Android 2.3.3 10 2 Not installed
> » Build, Execution, Deployment
» You can also start it : 3
» Tools
from Android Studio
|| Show Package Details
Launch Standalone SDK Manager Preview packages available! Switch to Preview Channel to see them
?) | Cancel Apply OK
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» Android tool

» Used to get APIs

and add-ons

» You can also start it
from Android Studio

¥ Appearance & Behavior
Appearance
Menus and Toolbars
v System Settings
Passwords
HTTP Proxy
Updates

Usage Statistics

Default Preferences

'TI‘ Appearance & Behavior » System Settings > Android SDK

Manager for the Android SDK and Tools used by Android Studio
Android SDK Location: /Users/Ibedogni/Library/Android/sdk Edit

| SDK Platforms

SDK Update Sites |

Below are the available SDK developer tools. Once installed, Android Studio will automatically
check for updates. Check "show package details" to display available versions of an SDK Tool.

Name Version Status
=/ Android SDK Build Tools Update Available: 23.0.2
™ Android SDK Tools 24.4.1 24.4.1 Installed

Android SDK -/ Android SDK Platform-Tools 23.1 rcl 23.1.0 rcl Update Available: 23.1.0
narol Documentation for Android SDK 1 Not installed

Notifications
Quick Lists
Keymap
» Editor
Plugins
» Build, Execution, Deployment
» Tools

GPU Debugging tools 1.0.3 Not installed
-| Android Support Repository, rev 24 24.0.0 Update Available: 25
Android Support Library 23.1.1 Not installed
Android Auto Desktop Head Unit emulator 1.1.0 Not installed
-| Google Play services, rev 27 27.0.0 Update Available: 29
-| Google Repository, rev 22 22.0.0 Update Available: 24
Coogle Play APK Expansion Library 3.0.0 Not installed
Coogle Play Billing Library 5.0.0 Not installed
Coogle Play Licensing Library 2.0.0 Not installed
Android Auto API Simulators 1.0.0 Not installed
GCoogle Web Driver 2.0.0 Not installed
= Intel x86 Emulator Accelerator (HAXM installer), rev 5.5 5.5.0 Update Available: 6.0.1
Android NDK 1.0.0 Not installed
LLDB 2.1.2589848 Not installed

[ Show Package Details

Launch Standalone SDK Manager Preview packages available! Switch to Preview Channel to see them

| Cancel | Apply [ ok |
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» Android tool

» Used to get APIs
and add-ons

» You can also start it
from Android Studio

00 Default Preferences

::} Appearance & Behavior > System Settings > Android SDK

v Appearance & Behavior Manager for the Android SDK and Tools used by Android Studio

Appearance Android SDK Location: /Users/Ibedogni/Library/Android/sdk Edit

Renu=la ciliooibars | SDK Platforms SDK Tools

v System Settings
These are the sites checked for Android SDK Updates Tools. When unchecked, the Android

P
HESOICS Studio SDK Manager will not check the site for updates. Adding additional add-on updates
HTTP Proxy sites can add new add-ons or extra SDK packages.
Updates Enabled Name URL
Usage Statistics @] Android Repository https://dl.google.com/android/repository/repository-1...
g @ Google Inc. https://dl.google.com/android /repository/addon.xml|
Android SDK ™  Google Inc. https://dl.google.com/android /repository/addon-6.xml
Notifications ™ Glass Development Kit, Google Inc. https://dl-ssl.google.com/glass/gdk/addon.xml
Onicilists @I Intel HAXM https://dl.google.com/android /repository/extras/intel/..
@] Android System Images https://dl.google.com/android /repository/sys-img/and...
Keymap [2] Android Wear System Images https://dl.google.com/android /repository/sys-img/and...
» Editor @ Android TV System Images https://dl.google.com/android /repository/sys-img/and...
Plugins @I Google APl add-on System Images https://dl.google.com/android /repository/sys-img/goo...
9 @] Google Inc. (x86 System Images) https://dl.google.com/android /repository/sys-img/x86..
» Build, Execution, Deployment
> Tools
or O

| | Force https://... sources to be fetched using http://...

Launch Standalone SDK Manager Preview packages available! Switch to Preview Channel to see them

) Cancel | Apply OK
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Your first Android application

»Go to File > New Project

Create New Project
New Project
Android Studio

Configure your new project

Application name: My Application

Company Domain: | Ibedogni.unibo.it

Package name: t.unibo.lbedogni.myapplication Edit

Project location: v/Users/lbedogni/AndroidStudioProjects/MyAppIica(ion

[ Cancel | Previous Finish
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Your first Android application

»Go to File > New Project

Create New Project

Target Android Devices

Select the form factors your app will run on

Different platforms may require separate SDKs

@ Phone and Tablet
Minimum SDK | API 15: Android 4.0.3 (IceCreamSandwich) v

Lower API levels target more devices, but have fewer features available.

By targeting APl 15 and later, your app will run on approximately 97.3% of the devices
that are active on the Google Play Store.

Help me choose

| | Wear

Minimum SDK | API 21: Android 5.0 (Lollipop) v
[TV

Minimum SDK | API 21: Android 5.0 (Lollipop) v

[ Android Auto

[) Glass

Minimum SDK | Glass Development Kit Preview &

| Cancel | | Previous \[ Next ] Finish
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Your first Android application

»Go to File > New Project

Create New Project

QAdd an activity to Mobile

Add No Activity

Blank Activity Empty Activity Fullscreen Activity Google AdMob Ads Activity
o ® I
Coogle Maps Activity Login Activity Master/Detail Flow Navigation Drawer Activity Scrolling Activity

| cancel | | Previous | [ Next | Finish
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Your first Android application

»Go to File > New Project

[ BoN | Create New Project

Q Customize the Activity

Creates a new blank activity with an app bar.

€ ;
_ Activity Name: MainActivity

Layout Name: activity_main

Title: MainActivity

Menu Resource Name: 'menu_main

[] Use a Fragment

Blank Activity

The name of the activity class to create

| Cancel | | Previous | Next
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Your first Android application

[ ] [ ] activity_main.xml - My Application - [~/AndroidStudioProjects/MyApplication]
m = ) % O & 45 W app v | D ¥ b @ ¢ & W 7
MyApplication app src main =res layout = ¢ activity_main.xml

2 i+ Android v D = | B 1 C MainActivity.java x © activity_main.xml x Preview - | m

.g v app <?xml Yersion:"l.e" encoding:"utf—a"b . . » ¢ ~ [ Nexus 4~ ~ (D AppTheme ﬁMainActivityv - Ig2l- 3

S > manifests c <Relativelayout xmlns:android="http://schemas.android.com/apk/res/android" H

5 > java xmlns:tools="http://schemas.android.com/tools" > F =

android:layout_width="match_parent" u) "> | S

- v Lares android:layout_height="match_parent" S

.é, drawable android:paddingBottom="16dp" v

& v layout android:paddingLeft="16dp" N

o Sacviymanxm | e -

+ actwvity_main.xmi android:paddingTop="16dp" s
> menu tools:context="it.unibo.lbedogni.myapplication.MainActivity"> &

o > mipmap

2 > values <TextView . -

2 (3 Gradle Scriots android:layout_width="wrap_content" =

A P android:layout_height="wrap_content" 3

~ android:text="Hello World!" /> =

v </Relativelayout> =

g
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b Design | Text =)

Terminal %+ 6: Android Monitor = 0: Messages & TODO Event Log [£] Gradle Console
Q Gradle build finished in 24s 949ms (2 minutes ago) | 1:1 |LF$ | UTF-8 |Context: <no context> | & ﬁ'x
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Testing on the emulator

»Select Run > Run App

O O Device Chooser

() Choose a running device

Device State Compatible Serlal Number

Nothing to show

(¢) Launch emulator

Android virtual device: ' Nexus 4 API 21 A

|| Use same device for future launches

(?) | Cancel \I oK l
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Creating an emulator

Android Virtual Device Manager

Device Definitions |

List of existing Android Virtual Devices located at /Users/lbedogni/.android /avd

AVD Name Target Name Platform APl Level CPU/ABI New...
+" Nexus4 Android 4.4.2 4.4.2 19 ARM (armeabi-v7a) o
e 00 Create new Android Virtual Device (AVD)
.
Can configure several  wwn
Device: \ 3
.
O ptl O n S Target: \ s
CPU/ABI: \ :
Keyboard: [?] Hardware keyboard present
Skin: \ a
Y Front Camera: None
Ou can create as MAaNyY .cme o
a S yo u Wa nt Memory Options: RAM: VM Heap:
Internal Storage: 200 | MiB 3
SD Card: -
(o) Size: | MiB :
( ;-File: Browse...
Conuilatian Antiane: |1 Snanshar [ llse Hosr GPLI
Cancel [ OK
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e Example Application

Hello world!

» Test in on the emulator

» You should see something
similar to this
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Example of AVD Creation

Android Virtual Device Manager

"W Your Virtual Devices
Android Studio

Virtual devices allow you to test
your application without having
to own the physical devices.

Create Virtual Device...

To prioritize which devices to
test your application on, visit the
\ndroid Das ards, where you
can get up-to-date information
on which devices are active in
the Android and Google Play
ecosystem.
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Example of AVD Creation

Virtual Device Configuration

AN Select Hardware
— y Choose a device definition

Category Resolution  Density
Phone Nexus S 480x800 hdpi

Size normal
Ratio notlong

Tablet Nexus One va 480x800 hdpi Density: xxhdpi
Wear Nexus 6P . 1440x2... 560dpi I

TV Nexus 6 . 1440x2... 560dpi

Nexus 5X : 1080x1... 420dpi
Nexus 5 1080x1... xxhdpi
Nexus 4 768x12... xhdpi
Galaxy Nexus 720x12... xhdpi
5.4" FWVGA 480x854 mdpi

5.1" WVGA 5.1" 480x800 mdpi

New Hardware Profile Import Hardware Profiles ’ Clone Device...
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Example of AVD Creation

£ System Image
"\ Select a system image

Release Name API Le...

¥ Show downloadable system images
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Lollipop

AP| Level

21

5.0
Android Open
Source Project

System Image

x86_64

Questions on API level?
See the API |




Example of AVD Creation

A Your Virtual Devices
H Android Studio

Ty... Name Resolution API Target Size on Disk Actions
(0] Nexus 5 API 21 1080 x 1920: x... 21 Android 5.0.1 ... 2GB £

Create Virtual Device...
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Example of AVD Creation
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i32 Hello world, Android!

» Anatomy of an application
»Activity: what is started
»View: what is seen
»Intent: how to communicate with others

»Mix of XML and Java
»Generally XML for layouts
»Java for the app logic
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The java and res folders

. . % Android  ~ © = | 8- I
» All the code of your application &
>The java folder contains... the ~om ="

- C
Java COd e ! v it.unibo.lbedogni.myapplication (androidTest)

2" % ApplicationTest

»Inside res there are a lot of i
resources

@ menu_main.xml

»Images T e

ic_launcher.png (5)
il ic_launcher.png (hdpi)

> La OutS i ic_launcher.png (mdpi)
y i ic_launcher.png (xhdpi)
i ic_launcher.png (xxhdpi)

1 i ic_launcher.png (oochdpl)
>Xm| fIIeS v values

= dimens.xml (2)

» AndroidManifest.xml S

» (% Gradle Scripts
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AndroidManifest.xml

i Android v D = | B I+
v app
v manifests
© AndroidManifest.xml

»Mandatory file for every " i

v it.unibo.lbedogni.myapplication

. . [= MainActivity
a p p I I Catl O n v it.unibo.lbedogni.myapplication (androidTest)

2" % ApplicationTest
v =res

> Contai n S : drawable

v layout

»Application declaration v e

@ menu_main.xml
- " v mipmap
> Pe rm ISSIOnS v ic_launcher.png (5)
il ic_launcher.png (hdpi)
- i} ic_launcher.png (mdpi)
> I nte nt fl Ite rS il ic_launcher.png (xhdpi)
i ic_launcher.png (xxhdpi)
i ic_launcher.png (xxxhdpi)
» Targets " Ervaes
[ dimens.xml (2)
« strings.xml
© styles.xml
b (2 Gradle Scripts
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»Via an AVD

Q%Fast, possible to have different resolutions, APls
%Not a real device

»On a real device

yYou get exactly what is deployed
%Must own a real device

»3S07
» Test in on AVDs.
» When you feel that the application is ready, go with a real device
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e,
i34 How to deploy
z S
2\ a | P—‘E'
RO LSS, SN
i

» Android applications must be signed before installing
them on a real device

m Run Tools VCS Window
}i: Make Project % Fg

Make Module ‘app " You need a key for this

Clean Project

Rebuild Project ' and you can generate one
cait Favors. - from the menu.

Edit Libraries and Dependencies...
Select Build Variant...

Build APK
Generate Signed APK...
Deploy Module to App Engine...
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» To be published on the market, you have to pay 25
Euro

» Lifetime fee, unlimited APPs
»Not required for the LAM class

»Upload the APK, and in few hours/days the APP is on
the play store

»Receive comments, improve, update
»Smartphone specific bugs? AVDs
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Android Developer Console

[N - — . ;
e Google play | Developer Console blu| Sign out
C
The big blue
= All applications w
= - ALL APPLICATIONS == com.consoledemo.bigblue
a1 Reports The little blue
com.consoledemao.littleblue
Settings
APP NAME PRICE ACTIVE INSTALLS AVG. RATING/TOTAL ERRORS LAST UPDATE STATUS
= Add new application E The big blue Free 12 5.00 / 1 0 Aug 15, 2012 Unpublished
The Handy Developer Guide  Free 756 % 5.00 / 2 6 Sep 26, 2012 Published
The big green Free — Draft
& The big red $2.00 136 - 14 Dec 3,2010  Published
The big yellow Free 3,672,387 5.00 / 1 119 Jan 18, 2012 Unpublished
E The little pink Free 7,452,652 % 5.00 / 1,986,412 8 Jun 14, 2012 Published
& The little red Free 2,412 * 3.33 / 335 341 Dec 8, 2010 Published
Page 1 of 7 | 2 Go to page Go

Luca Bedogni = Programming with Android — SDK install and initial setup 31



